DevToolPal
ไทย

แปลง Unix Timestamp

แปลง Unix timestamp (วินาที มิลลิวินาที ไมโครวินาที หรือนาโนวินาที) เป็นวันที่ที่อ่านได้ และแปลงกลับ

ทำงานในเครื่อง ไม่มีการอัปโหลด

ตัวเลือก

Timestamp หรือวันที่

ผลลัพธ์

ผลลัพธ์จะแสดงที่นี่

เครื่องมือนี้ทำอะไร

แปลงระหว่าง Unix timestamp กับวันที่ที่คนอ่านได้ วาง timestamp ในหน่วยวินาที มิลลิวินาที ไมโครวินาที หรือนาโนวินาที เพื่อดูเป็น Unix วินาที มิลลิวินาที และไมโครวินาที เป็นวันที่ที่อ่านง่ายตาม UTC และเวลาท้องถิ่นของคุณ (เขียนเป็นภาษาของหน้า) และในรูปแบบ ISO 8601, RFC 9557, RFC 5322 และ HTTP-date พร้อมบอกว่าผ่านมานานเท่าไรแล้ว หรือวางวันที่ในรูปแบบที่รองรับเพื่อรับ timestamp

วิธีใช้งาน

  1. อินพุตเริ่มต้นด้วยเวลาปัจจุบัน กด ตอนนี้ เมื่อใดก็ได้เพื่อรีเซ็ต
  2. วาง timestamp หรือวันที่ หรือเลือกวันที่ (และเวลาละเอียดถึงวินาทีถ้าต้องการ) จากตัวเลือกใต้ช่องอินพุต ผลลัพธ์จะอัปเดตขณะพิมพ์
  3. อ่านเป็น แสดงว่าอินพุตถูกตีความอย่างไร หากเครื่องมือเดาหน่วยของตัวเลขผิด ให้เลือกเองที่ หน่วยของอินพุต
  4. คลิก คัดลอก ข้างแถวใดก็ได้

รูปแบบอินพุตที่รองรับ

  • เวลา Unix: 1700000000, 1700000000000, 1700000000000000 และทศนิยมอย่าง 1700000000.5
  • ISO 8601 / RFC 3339 และ RFC 9557: 2024-01-01T08:00:00Z, 2024-01-01 08:00, 2024-01-01T08:00+08:00[Asia/Shanghai]
  • วันที่แบบตัวเลขตามเวลาท้องถิ่น: 2024/1/31, 31-01-2024, 31.01.2024, 1/31/2024 5:30 pm (ถ้าใช้ทับ เดือนจะมาก่อน เว้นแต่ตัวเลขแรกมากกว่า 12)
  • วันที่ภาษาจีนและภาษาญี่ปุ่น: 2026年10月8日 12:12:39
  • วันที่แบบสัมพัทธ์: now, today, yesterday 18:00, tomorrow, +3 days, 2 hours ago, in 1 year 2 months
  • RFC 5322 และ HTTP-date: Mon, 01 Jan 2024 00:00:00 GMT, 1 Jan 24 08:00 +0800, Monday, 01-Jan-24 00:00:00 GMT, Mon Jan 1 00:00:00 2024

คำถามที่พบบ่อย

› Unix timestamp คืออะไร

จำนวนวินาที (หรือมิลลิวินาที) นับตั้งแต่ 1970-01-01 00:00:00 UTC หรือที่เรียกว่า epoch time ค่านี้เท่ากันทุกที่ในโลกไม่ว่าจะอยู่เขตเวลาใด

› การตรวจจับอัตโนมัติแยกวินาทีกับมิลลิวินาทีอย่างไร

ดูจากจำนวนหลัก ตัวเลข 10 หลักคือวินาที 13 หลักคือมิลลิวินาที 16 หลักคือไมโครวินาที และ 19 หลักคือนาโนวินาที เลือกหน่วยเองเพื่อแทนที่ผลการตรวจจับได้

› วางวันที่รูปแบบใดได้บ้าง

ISO 8601 / RFC 3339 (2024-01-01T08:00:00+08:00), RFC 9557 พร้อมเขตเวลา (2024-01-01T08:00[Asia/Shanghai]), วันที่แบบ ปี-เดือน-วัน วัน-เดือน-ปี และ เดือน/วัน/ปี ที่จะมีเวลาหรือไม่ก็ได้, วันที่แบบสัมพัทธ์ (now, yesterday, 3 days ago, in 2 weeks), วันที่ในอีเมลแบบ RFC 5322 และ HTTP-date ทั้งสามรูปแบบ (IMF-fixdate, RFC 850 และ asctime) รูปแบบอื่นที่เบราว์เซอร์เข้าใจก็ใช้ได้เช่นกัน

› วันที่ที่ไม่มีออฟเซ็ตอยู่ในเขตเวลาใด

อยู่ในเขตเวลาท้องถิ่นของคุณ รวมถึงวันที่เปล่า ๆ อย่าง 2024-01-01 (เที่ยงคืนตามเวลาท้องถิ่น) เติม Z หรือออฟเซ็ตอย่าง +08:00 เพื่อใช้ UTC หรือเขตเวลาอื่น หรือต่อท้ายด้วยเขตเวลา IANA ในวงเล็บเหลี่ยมตามที่ RFC 9557 อนุญาต