DevToolPal
IT

Convertitore di timestamp Unix

Converti timestamp Unix (secondi, millisecondi, micro o nanosecondi) in date leggibili e viceversa.

Eseguito in locale, mai caricato

Opzioni

Timestamp o data

Risultato

Il risultato apparirà qui

Cosa fa

Converte tra timestamp Unix e date leggibili. Incolla un timestamp in secondi, millisecondi, microsecondi o nanosecondi per vederlo in secondi, millisecondi e microsecondi Unix, come data leggibile in UTC e nella tua ora locale (scritta nella lingua della pagina) e come ISO 8601, RFC 9557, RFC 5322 e HTTP-date, insieme a quanto tempo fa corrisponde. Incolla una data in uno qualsiasi dei formati supportati per ottenere il suo timestamp.

Come si usa

  1. L’input parte dall’ora attuale. Premi Adesso in qualsiasi momento per reimpostarlo.
  2. Incolla un timestamp o una data, oppure scegli una data (e, se vuoi, un’ora fino ai secondi) con il selettore sotto l’input. I risultati si aggiornano mentre scrivi.
  3. Letto come mostra come è stato interpretato l’input. Se l’unità di un numero viene indovinata male, sceglila in Unità di input.
  4. Fai clic su Copia accanto a qualsiasi riga.

Formati di input supportati

  • Tempo Unix: 1700000000, 1700000000000, 1700000000000000, decimali come 1700000000.5
  • ISO 8601 / RFC 3339 e RFC 9557: 2024-01-01T08:00:00Z, 2024-01-01 08:00, 2024-01-01T08:00+08:00[Asia/Shanghai]
  • Date numeriche in ora locale: 2024/1/31, 31-01-2024, 31.01.2024, 1/31/2024 5:30 pm (con le barre il mese viene prima, a meno che il primo numero superi 12)
  • Date in cinese e giapponese: 2026年10月8日 12:12:39
  • Date relative: now, today, yesterday 18:00, tomorrow, +3 days, 2 hours ago, in 1 year 2 months
  • RFC 5322 e HTTP-date: Mon, 01 Jan 2024 00:00:00 GMT, 1 Jan 24 08:00 +0800, Monday, 01-Jan-24 00:00:00 GMT, Mon Jan 1 00:00:00 2024

Domande frequenti

› Che cos’è un timestamp Unix?

Il numero di secondi (o millisecondi) trascorsi dal 1970-01-01 00:00:00 UTC, detto anche tempo epoch. È uguale in tutto il mondo, indipendentemente dal fuso orario.

› Come sceglie il rilevamento automatico tra secondi e millisecondi?

In base alla lunghezza. I numeri a dieci cifre sono secondi, a tredici millisecondi, a sedici microsecondi e a diciannove nanosecondi. Scegli un’unità manualmente per forzarla.

› Quali formati di data posso incollare?

ISO 8601 / RFC 3339 (2024-01-01T08:00:00+08:00), RFC 9557 con fuso orario (2024-01-01T08:00[Asia/Shanghai]), date A-M-G, G-M-A e M/G/A con ora facoltativa, date relative (now, yesterday, 3 days ago, in 2 weeks), date e-mail RFC 5322 e tutte e tre le forme di HTTP-date (IMF-fixdate, RFC 850 e asctime). Funziona anche qualsiasi altro formato che il browser capisce.

› In quale fuso orario sono le date senza offset?

Nel tuo fuso orario locale, anche una semplice data come 2024-01-01 (mezzanotte locale). Aggiungi Z o un offset come +08:00 per UTC o un altro fuso, oppure accoda un fuso IANA tra parentesi quadre come consente RFC 9557.